View Issue Details

IDProjectCategoryView StatusLast Update
0000342Adventure PHP FrameworkBugpublic2019-01-22 06:19
ReporterGeneral CrimeAssigned ToGeneral Crime 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.4 
Target Version4.0Fixed in Version4.0 
Summary0000342: TextLenghtValidation with minlenght=1 ist invalid with subject 0
DescriptionIf I enter 0 for a text box with "minlength = 1". Will the field be marked as invalid?

Behavior is correct according to PHP.net: http://php.net/manual/de/function.empty.php
Additional InformationI sent you a pull request.
The function is empty so I think then no more sense. Since "subject" always exists.
TagsNo tags attached.
Codereferenz: ([Datei]:[Zeile])TextLenghtValidator:74
Namespacetools

Activities

General Crime

2019-01-21 12:21

developer   ~0000887

Unfortunately, I had not thought that the class has inherited so the $ subject could not be initialized into the parameter if it is not there.
However, I have set the variable nevertheless with a transfer of an empty string. So that should not be a problem !?

General Crime

2019-01-21 13:01

developer   ~0000888

So i add some TestCases and now all works fine.

Issue History

Date Modified Username Field Change
2019-01-21 12:09 General Crime New Issue
2019-01-21 12:09 General Crime Status new => assigned
2019-01-21 12:09 General Crime Assigned To => General Crime
2019-01-21 12:21 General Crime Note Added: 0000887
2019-01-21 13:01 General Crime Note Added: 0000888
2019-01-22 06:19 General Crime Status assigned => resolved
2019-01-22 06:19 General Crime Resolution open => fixed
2019-01-22 06:19 General Crime Fixed in Version => 4.0