View Issue Details

IDProjectCategoryView StatusLast Update
0000317Adventure PHP FrameworkCode-Verbesserung // Code improvementpublic2017-08-14 14:43
Reporterthalo1Assigned ToChristianAchatz 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.3 
Target Version3.4Fixed in Version3.4 
Summary0000317: Frontcontroller should throw an exception if context is not set
DescriptionOtherwise it is not possible to create a SINGLETON/SESSIONSINGLETON within different namespaces.
TagsNo tags attached.
Codereferenz: ([Datei]:[Zeile])
Namespacenone

Activities

ChristianAchatz

2017-08-06 22:32

administrator   ~0000775

Since the original issue has been detected in ServiceManager (creating same instance for different applications w/ separate context), the ServiceManager and DIServiceManager should also throw an exception in case empty/null context is applied.

ChristianAchatz

2017-08-14 12:40

administrator   ~0000776

Changed implementation of

- ServiceManager
- DIServiceManager
- FrontController

to avoid context clashes with empty context applied to the Frontcontroller.

Issue History

Date Modified Username Field Change
2017-07-23 16:17 thalo1 New Issue
2017-07-24 22:24 ChristianAchatz Assigned To => ChristianAchatz
2017-07-24 22:24 ChristianAchatz Status new => assigned
2017-08-06 22:32 ChristianAchatz Note Added: 0000775
2017-08-14 12:40 ChristianAchatz Note Added: 0000776
2017-08-14 12:43 ChristianAchatz Status assigned => resolved
2017-08-14 12:43 ChristianAchatz Fixed in Version => 3.4
2017-08-14 12:43 ChristianAchatz Resolution open => fixed
2017-08-14 14:43 ChristianAchatz Product Version => 3.3
2017-08-14 14:43 ChristianAchatz Target Version => 3.4