View Issue Details

IDProjectCategoryView StatusLast Update
0000291Adventure PHP FrameworkCode-Verbesserung // Code improvementpublic2018-08-25 12:51
ReporterdaveAssigned ToChristianAchatz 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.1 
Target Version4.0Fixed in Version4.0 
Summary0000291: Missing Class "JSMin" for HtmlHeader JsCssPackager
DescriptionJsCssPackager of HtmlHeader extension uses external class "JSMin" which is not official included in APF Framework

-> Find a way to easily include the class
TagsNo tags attached.
Codereferenz: ([Datei]:[Zeile])
Namespaceextensions

Activities

ChristianAchatz

2017-03-13 20:53

administrator   ~0000764

Maybe using https://packagist.org/packages/mrclay/jsmin-php or other packages available through Packagist?

ChristianAchatz

2018-08-25 12:51

administrator   ~0000835

dave,

due to licensing reasons, JSMin has not been included in the APF package (see also Google's ReCaptcha library in ReCaptchaValidator).

For this reason, please include https://github.com/rgrove/jsmin-php/blob/master/jsmin.php into your project and autoloading either manually or via packagist.

On packagist.org you'll find i.e. https://packagist.org/packages/mrclay/jsmin-php to be included in your composer.json as follows:

composer require mrclay/jsmin-php

Issue History

Date Modified Username Field Change
2016-03-30 23:25 dave New Issue
2016-08-10 14:21 ChristianAchatz Target Version 3.3 => 3.4
2017-03-13 20:53 ChristianAchatz Note Added: 0000764
2017-09-08 15:22 ChristianAchatz Target Version 3.4 => 4.0
2018-08-25 12:51 ChristianAchatz Note Added: 0000835
2018-08-25 12:51 ChristianAchatz Assigned To => ChristianAchatz
2018-08-25 12:51 ChristianAchatz Status new => closed
2018-08-25 12:51 ChristianAchatz Resolution open => fixed
2018-08-25 12:51 ChristianAchatz Fixed in Version => 4.0