View Issue Details

IDProjectCategoryView StatusLast Update
0000188Adventure PHP FrameworkNeues Feature // New Featurepublic2018-08-25 15:07
ReporterChristianAchatzAssigned ToChristianAchatz 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version2.1 
Target VersionFixed in Version 
Summary0000188: Allow context fallback for context-independent configurations similar to the environment fallback
DescriptionAt present, the ConfigurationManager supports a fallback mechanism to load a DEFAULT configuration file in case a special environment file is not present (applies to all file-based configuration providers).

With this change, the ConfigurationManager and it's file-based ConfigurationProvider implementations should support a fallback for context-based configuration files as well. This is especially interesting, in case an application contains common configuration files that can be used in various use cases whereas some files are adapted to the respective context.
TagsNo tags attached.
Codereferenz: ([Datei]:[Zeile])
Namespacecore

Activities

ChristianAchatz

2014-05-17 20:33

administrator   ~0000349

First draft implementation failed, since combination of environment fallback and context fallback always causes fallback to DEFAULT environment. Currently no solution in mind, thus postponed to 2.2.

ChristianAchatz

2015-09-05 18:18

administrator   ~0000608

Moved to 3.2 to shape scope for 3.1.

ChristianAchatz

2018-08-25 15:00

administrator   ~0000837

Closing since this is not feasible from a current implementation POV.

Issue History

Date Modified Username Field Change
2014-05-10 16:24 ChristianAchatz New Issue
2014-05-10 16:24 ChristianAchatz Status new => assigned
2014-05-10 16:24 ChristianAchatz Assigned To => ChristianAchatz
2014-05-17 20:33 ChristianAchatz Note Added: 0000349
2014-05-17 20:33 ChristianAchatz Target Version 2.1 => 3.0
2014-09-06 15:09 ChristianAchatz Target Version 3.0 => 3.1
2014-09-06 15:28 ChristianAchatz Assigned To ChristianAchatz =>
2015-09-05 18:18 ChristianAchatz Note Added: 0000608
2015-09-05 18:18 ChristianAchatz Target Version 3.1 => 3.2
2016-03-23 14:01 ChristianAchatz Target Version 3.2 => 3.3
2016-08-10 14:20 ChristianAchatz Target Version 3.3 => 3.4
2017-11-04 17:20 ChristianAchatz Target Version 3.4 => 4.0
2018-08-25 15:00 ChristianAchatz Note Added: 0000837
2018-08-25 15:00 ChristianAchatz Assigned To => ChristianAchatz
2018-08-25 15:00 ChristianAchatz Status assigned => closed
2018-08-25 15:00 ChristianAchatz Resolution open => fixed
2018-08-25 15:07 ChristianAchatz Target Version 4.0 =>