View Issue Details

IDProjectCategoryView StatusLast Update
0000185Adventure PHP FrameworkNeues Feature // New Featurepublic2015-10-12 12:19
ReporterChristianAchatzAssigned ToChristianAchatz 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0 
Summary0000185: POC: switch registration of known tags from Document instance to static Document property
DescriptionAt present, known tags have to be registered with each Document instance separately. This has been there for long times to increase performance parsing templates starting with the known tags.

As of 2.2 the parser will be focused on tags defined within templates and no longer on known tags. This (theoretically) allows to register known tags globally for all Document instances.

With this issue a POC should be conducted to check whether it is possible to switch from instance to static field for the list of known tags and which interferences this may cause.

So far:

1) Pros
- Known tag definitions must be added only once
- Known tag definitions can be added centrally within bootstrap file
- No performance impact with new 2.2 parser implementation
- Memory consumption decreases due to smaller objects (so may construction performance of Document instances)

2) Cons
- Overwriting of known tags within dedicated instances no longer possible (or new concept to be introduced)
- Migration effort to release where feature is introduced higher
Tagscore-taglibs, documentcontroller, pagecontroller
Codereferenz: ([Datei]:[Zeile])pagecontroller.php
Namespacecore

Relationships

related to 0000186 closedChristianAchatz Save taglibs as associative array to allow the developer to overwrite core tags 

Activities

ChristianAchatz

2014-06-21 18:38

administrator   ~0000398

Realization done in one of the last check-ins to master-Branch.

Overwriting of tags within one instance also realized with new concept:

- Document::addTagLib() (static): allows global definition/registration of tag
- Document::addInstanceTagLib() (per instance): allows definition/registration of tag for a specific instance

Specific tag definitions overwrite global tag definitions, naturally.

Issue History

Date Modified Username Field Change
2014-04-25 10:08 ChristianAchatz New Issue
2014-04-25 10:08 ChristianAchatz Tag Attached: documentcontroller
2014-04-25 10:09 ChristianAchatz Tag Attached: core-taglibs
2014-04-25 10:09 ChristianAchatz Tag Attached: pagecontroller
2014-05-04 10:55 ChristianAchatz Relationship added related to 0000186
2014-05-04 10:55 ChristianAchatz Assigned To => ChristianAchatz
2014-05-04 10:55 ChristianAchatz Status new => assigned
2014-06-21 18:38 ChristianAchatz Note Added: 0000398
2014-06-21 18:38 ChristianAchatz Status assigned => resolved
2014-06-21 18:38 ChristianAchatz Fixed in Version => 3.0
2014-06-21 18:38 ChristianAchatz Resolution open => fixed
2015-10-12 12:19 ChristianAchatz Status resolved => closed