View Issue Details

IDProjectCategoryView StatusLast Update
0000171Adventure PHP FrameworkCode-Verbesserung // Code improvementpublic2015-10-12 12:20
ReporterChristianAchatzAssigned ToChristianAchatz 
PrioritynormalSeveritytweakReproducibilityN/A
Status closedResolutionfixed 
Product Version2.0 
Target Version2.1Fixed in Version2.1 
Summary0000171: Remove content handling on transformation time with document controllers
DescriptionAs of now, the content of a document is injected into a document controller whereas the attributes of the current node are not. This causes the page controller to copy content from the current node to the document controller and back during transformation time.

With this issue, the content copy should be removed to avoid "copy on change" executions as manipulating the content is a) not recommended and b) there are a lot of methods encapsulating content adaptions (setStringPlaceHolder() etc.).
TagsNo tags attached.
Codereferenz: ([Datei]:[Zeile])
Namespacecore

Activities

ChristianAchatz

2014-03-28 17:40

administrator   ~0000285

Preparation to be done in 2.1:
- Remove all explicit manipulations of the content of a DOM node within controllers
- Write migration documentation in prepration on 2.2

ChristianAchatz

2014-04-01 23:28

administrator   ~0000288

Decided to include in 2.1 already since changes are easy to implement.

ChristianAchatz

2014-04-10 15:52

administrator   ~0000292

Migration documentation to be written.

ChristianAchatz

2014-04-11 12:38

administrator   ~0000293

Done.

Issue History

Date Modified Username Field Change
2014-03-04 21:03 ChristianAchatz New Issue
2014-03-04 21:03 ChristianAchatz Target Version => 3.0
2014-03-28 17:40 ChristianAchatz Note Added: 0000285
2014-03-28 17:40 ChristianAchatz Assigned To => ChristianAchatz
2014-03-28 17:40 ChristianAchatz Status new => assigned
2014-04-01 19:33 ChristianAchatz Target Version 3.0 => 2.1
2014-04-01 23:28 ChristianAchatz Note Added: 0000288
2014-04-01 23:30 ChristianAchatz Status assigned => resolved
2014-04-01 23:30 ChristianAchatz Fixed in Version => 2.1
2014-04-01 23:30 ChristianAchatz Resolution open => fixed
2014-04-10 15:52 ChristianAchatz Note Added: 0000292
2014-04-11 12:38 ChristianAchatz Note Added: 0000293
2015-10-12 12:20 ChristianAchatz Status resolved => closed