View Issue Details

IDProjectCategoryView StatusLast Update
0000131Adventure PHP FrameworkNeues Feature // New Featurepublic2015-10-12 12:20
ReporterChristianAchatzAssigned ToChristianAchatz 
PriorityhighSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version2.1 
Target VersionFixed in Version2.1 
Summary0000131: Refactor existing build scripts for APF release and include into SVN
DescriptionAt present, build scripts can only be executed locally on environments that have been prepared. Within this feature request, existing bulild scripts should be refactored and integrated into SVN to enable all developers to build an APF release locally or on integration servers.
TagsNo tags attached.
Codereferenz: ([Datei]:[Zeile])
Namespacenone

Activities

ChristianAchatz

2014-04-14 15:56

administrator   ~0000296

* Snapshot releases migrated.
* Scripts to be relocated to tools repo.

ChristianAchatz

2014-04-14 15:56

administrator   ~0000297

Next steps:
- Refactor release build scripts.
- Integrate snapshot build script into "tools" repo.
- Document local DEV setup for APF docs page.
- Document build scripts.

ChristianAchatz

2014-04-15 22:54

administrator   ~0000302

Initial Check-in done. See https://github.com/AdventurePHP/tools/tree/master/build. doxygen + dot API docs generation open due to issues with doxygen under cygwin on WIN.

ChristianAchatz

2014-04-19 15:28

administrator   ~0000306

Doxygen issue solved. Code already pushed to https://github.com/AdventurePHP/tools.

ChristianAchatz

2014-04-23 16:15

administrator   ~0000308

To allow better local development setup repo structure will be adapted once more. Still some coding work to do before documentation.

ChristianAchatz

2014-04-28 21:44

administrator   ~0000318

Last edited: 2014-05-01 22:36

View 2 revisions

Build scripts refatored. Documentation to be created under http://wiki.adventure-php-framework.org/Erstellen_eines_Builds.

ChristianAchatz

2014-05-02 14:20

administrator   ~0000319

Done. Documentation created under

http://wiki.adventure-php-framework.org/Erstellen_eines_Builds/en (English)
http://wiki.adventure-php-framework.org/Erstellen_eines_Builds (German)

Issue History

Date Modified Username Field Change
2014-01-25 14:42 ChristianAchatz New Issue
2014-03-08 16:24 ChristianAchatz Assigned To => ChristianAchatz
2014-03-08 16:24 ChristianAchatz Status new => assigned
2014-04-14 15:56 ChristianAchatz Note Added: 0000296
2014-04-14 15:56 ChristianAchatz Note Added: 0000297
2014-04-15 22:54 ChristianAchatz Note Added: 0000302
2014-04-19 15:28 ChristianAchatz Note Added: 0000306
2014-04-23 16:15 ChristianAchatz Note Added: 0000308
2014-04-28 21:44 ChristianAchatz Note Added: 0000318
2014-05-01 22:36 ChristianAchatz Note Edited: 0000318 View Revisions
2014-05-02 14:20 ChristianAchatz Note Added: 0000319
2014-05-02 14:20 ChristianAchatz Status assigned => resolved
2014-05-02 14:20 ChristianAchatz Fixed in Version => 2.1
2014-05-02 14:20 ChristianAchatz Resolution open => fixed
2015-10-12 12:20 ChristianAchatz Status resolved => closed