Voraussetzungen APF 2.1 und APF 3.0

Alle Fragen zur Installation und zu den erhältlichen Versionen sind hier an der richtigen Adresse. // All questions on installing the APF.
Antworten
Benutzeravatar
dave
Beiträge: 903
Registriert: 04.02.2011, 19:03:57
Wohnort: Berlin
Kontaktdaten:

Voraussetzungen APF 2.1 und APF 3.0

Beitrag von dave » 21.02.2015, 14:59:43

Hi zusammen,

ich bin wieder zurück :) Mit neuer Kraft und einer neuen Idee wage ich nochmals den Schritt, mich einer komplexen Anwendung zu stellen und diese zu realisieren. Mal sehen, wie weit das diesmal klappt. Und mal schauen, inwieweit ich hier meinen Beitrag leisten kann.

Ich möchte dabei natürlich mit der neuen Version arbeiten. Wie ich bereits gelesen habe, wird schon fleissig am APF 3.0 gebastelt, wie weit ist das bereits einsetzbar? Und welche Vorraussetzungen müssen erfüllt sein? Im speziellen meine ich dabei PHP und mySQL. Bei mir läuft momentan noch PHP 5.3, komme ich damit hin?

Lässt sich das einmal kurz und übersichtlich zusammenfassen? Eine Infos diesbezüglich auf der APF-Seite wäre auch nicht verkehrt, oder habe ich das einfach nur übersehen?

Benutzeravatar
dr.e.
Administrator
Beiträge: 4555
Registriert: 04.11.2007, 16:13:53

Re: Voraussetzungen APF 2.1 und APF 3.0

Beitrag von dr.e. » 22.02.2015, 02:27:20

Hallo dave & welcone back! :)
Wie ich bereits gelesen habe, wird schon fleissig am APF 3.0 gebastelt, wie weit ist das bereits einsetzbar?
Coding ist zu einem großen Teil abgeschlossen (siehe http://tracker.adventure-php-framework. ... p_page.php) und du kannst ohne Probleme schon einsetzen, da die umfassensten Änderungen schon erledigt sind. Offen sind an einigen Stellen noch Dokumentation, das wird in den nächsten Wochen vervollständigt und online gestellt.
Und welche Vorraussetzungen müssen erfüllt sein? Im speziellen meine ich dabei PHP und mySQL. Bei mir läuft momentan noch PHP 5.3, komme ich damit hin?
PHP 5.4 ist voraussetzung, da Traits eingesetzt werden und auf Namespaces gesetzt wird.
Lässt sich das einmal kurz und übersichtlich zusammenfassen? Eine Infos diesbezüglich auf der APF-Seite wäre auch nicht verkehrt, oder habe ich das einfach nur übersehen?
Schau mal im Wiki unter http://wiki.adventure-php-framework.org ... .0_auf_2.1 bzw. http://wiki.adventure-php-framework.org ... .1_auf_3.0, da findest du schon eine Menge. Sobald die offizielle Doku aktualisiert ist, stehen dort natürlich alle Voraussetzungen.

Solltest du konkrete Fragen haben, lass mich das gerne wissen! :)
Viele Grüße,
Christian

Benutzeravatar
dave
Beiträge: 903
Registriert: 04.02.2011, 19:03:57
Wohnort: Berlin
Kontaktdaten:

Re: Voraussetzungen APF 2.1 und APF 3.0

Beitrag von dave » 22.02.2015, 10:52:34

Klasse!
Dann werde ich mal das APF3 verwenden und mein Feedback einfliessen lassen. Erste Sahne :)

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast